Any way to disable zooming in/out through mouse wheel?

Hello everyone!

I'd like to start by saying that I really enjoy using CircuitLab, it is very easy to use and a well thought-out product in many ways, which makes it quite usable.

However, one thing that I find irritating while using Apple's wireless mouse is that zooming in/out, as activated by unintentionally sliding your finger on the surface of the mouse becomes bothering.

Is there a way to disable zooming in/out through the mouse as I totally do not mind using the zoom in/out controls in the lower right corner of the screen?

Thanks a lot and again, I really enjoy using CircuitLab.

Thanks a bunch!


A maker at the Origin Base Maker space, Dubai (UAE) and a Highschool Computer Science teacher at the International School of Arts and Siences (ISAS), Dubai (UAE)

by orwa.diraneyya
June 22, 2015

I don't think there's any way to disable mouse zooming in CL.

You might be able to do it by disabling the relevant aspect of the mouse behaviour in whatever Apple OS you are using.

by signality
June 23, 2015

This is old, but I experience this same frustration. However the issue is not that you can zoom with the magic mouse, the issue is that zoom is done with both the up/down stroke AND the left/right stroke.

The left/right stroke controlling zoom is what needs to be eliminated.

by Shandor
December 04, 2015

Post a Reply

Please sign in or create an account to comment.