JS not enabled message (with JS enabled)

I can get to the editor sometimes but a lot of the time I am just redirected to the .../nojs page. Once this occurs I can't get back in to it without restarting the computer.

I've had this behaviour in Firefox on two different OSs:

Firefox 10.0.2 for Ubuntu Canonical 1.0 (Ubuntu 11.10, 64bit) Firefox 10.0.2 (Windows 7 Ultimate 32bit)

I have Javascript enabled in both (hence having been able to access the editor sometimes). I've been trying to narrow down the problem and have a feeling that this only occurred after accessing Google+ in the same browser but have yet to confirm this (as it is a slow process). Shutting down all instances of the browser and restarting has no effect once the redirect has occurred. When I hover over any links to the editor they now point to the .../nojs page so I assume that (for some reason) the site is not actually checking whether JS is enabled.

JS's are working on other sites so it is definitely a problem with the check on this site.

by Seye
March 01, 2012

Hi Seye, we recently changed the way we load the editor in order to enable Ctrl+click of the button to open it in a new tab. As we just deployed new code about an hour ago, can you try to make sure your browser isn't inadvertently caching older versions of parts of our website?

In Firefox, load up https://www.circuitlab.com/ and then hit Ctrl+F5. This forces the browser to re-request all page elements. Please let me know if that fixes things for you.

by mrobbins
March 01, 2012

That's worked.

The link still says .../nojs when I hover over it but when clicked it goes to the editor. I guess that the JS check is on the nojs page and it redirects to the editor from there.


by Seye
March 01, 2012

Post a Reply

Please sign in or create an account to comment.